aboutsummaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorTed Gould <ted@gould.cx>2012-08-21 21:47:41 -0500
committerTed Gould <ted@gould.cx>2012-08-21 21:47:41 -0500
commit3259be54400c65291b31bf42322d6e38721c9dbb (patch)
tree23bce0d86e40b4e3fe7a2093ad9fbc87404fe036 /Makefile.am
parent58e97323dbbbd98cffea4b29003b34d965597203 (diff)
downloadlightdm-remote-session-remoteconfigure-3259be54400c65291b31bf42322d6e38721c9dbb.tar.gz
lightdm-remote-session-remoteconfigure-3259be54400c65291b31bf42322d6e38721c9dbb.tar.bz2
lightdm-remote-session-remoteconfigure-3259be54400c65291b31bf42322d6e38721c9dbb.zip
Creating the session configuration file
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am20
1 files changed, 18 insertions, 2 deletions
diff --git a/Makefile.am b/Makefile.am
index 3baade8..9e0e749 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -1,8 +1,24 @@
-
EXTRA_DIST =
-
CLEANFILES =
+###############################
+# The session configuration
+###############################
+
+lightdm_sessiondir = $(datadir)/lightdm/remote-sessions
+lightdm_session_DATA = \
+ uccsconfigure.desktop
+
+%.desktop: %.desktop.in
+ @sed -e "s|\@pkglibexecdir\@|$(pkglibexecdir)|" $< > $@
+
+EXTRA_DIST += uccsconfigure.desktop.in
+CLEANFILES += uccsconfigure.desktop
+
+###############################
+# Dist check stuff
+###############################
+
DISTCHECK_CONFIGURE_FLAGS = --enable-localinstall
dist-hook: