aboutsummaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am20
1 files changed, 18 insertions, 2 deletions
diff --git a/Makefile.am b/Makefile.am
index 3baade8..9e0e749 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -1,8 +1,24 @@
-
EXTRA_DIST =
-
CLEANFILES =
+###############################
+# The session configuration
+###############################
+
+lightdm_sessiondir = $(datadir)/lightdm/remote-sessions
+lightdm_session_DATA = \
+ uccsconfigure.desktop
+
+%.desktop: %.desktop.in
+ @sed -e "s|\@pkglibexecdir\@|$(pkglibexecdir)|" $< > $@
+
+EXTRA_DIST += uccsconfigure.desktop.in
+CLEANFILES += uccsconfigure.desktop
+
+###############################
+# Dist check stuff
+###############################
+
DISTCHECK_CONFIGURE_FLAGS = --enable-localinstall
dist-hook: