aboutsummaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorTed Gould <ted@gould.cx>2012-09-14 14:20:03 -0500
committerTed Gould <ted@gould.cx>2012-09-14 14:20:03 -0500
commit3e7f9c00c55b795def0c70fd2de5fc37aa2495ca (patch)
tree926225988a636096f95523d9618c2ee4f1f6686a /Makefile.am
parent7721cce2f593a5aa5a5b94e14eef8d890c7c36ad (diff)
downloadlightdm-remote-session-remoteconfigure-3e7f9c00c55b795def0c70fd2de5fc37aa2495ca.tar.gz
lightdm-remote-session-remoteconfigure-3e7f9c00c55b795def0c70fd2de5fc37aa2495ca.tar.bz2
lightdm-remote-session-remoteconfigure-3e7f9c00c55b795def0c70fd2de5fc37aa2495ca.zip
Add a small binary to be the wrapper
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am13
1 files changed, 13 insertions, 0 deletions
diff --git a/Makefile.am b/Makefile.am
index e8cec00..1325ca5 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -41,6 +41,19 @@ EXTRA_DIST += uccsconfigure-session.in
CLEANFILES += uccsconfigure-session
###############################
+# The session wrapper
+###############################
+
+pkglibexec_PROGRAMS = \
+ uccsconfigure-session-wrapper
+
+uccsconfigure_session_wrapper_SOURCES = \
+ uccsconfigure-session-wrapper.c
+uccsconfigure_session_wrapper_CFLAGS = \
+ -DPKGDATADIR="\"$(pkgdatadir)\"" \
+ -Wall -Werror
+
+###############################
# Apparmor for session script
###############################