aboutsummaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am15
1 files changed, 15 insertions, 0 deletions
diff --git a/Makefile.am b/Makefile.am
index 9e0e749..d1882ce 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -16,6 +16,21 @@ EXTRA_DIST += uccsconfigure.desktop.in
CLEANFILES += uccsconfigure.desktop
###############################
+# The session script
+###############################
+
+session_startdir = $(pkglibexecdir)
+session_start_SCRIPTS = \
+ uccsconfigure-session
+
+uccsconfigure-session: uccsconfigure-session.in
+ @sed -e "s|\@pkglibexecdir\@|$(pkglibexecdir)|" $< > $@
+ @chmod +x $@
+
+EXTRA_DIST += uccsconfigure-session.in
+CLEANFILES += uccsconfigure-session
+
+###############################
# Dist check stuff
###############################