aboutsummaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorTed Gould <ted@gould.cx>2012-08-21 21:55:14 -0500
committerTed Gould <ted@gould.cx>2012-08-21 21:55:14 -0500
commit7f1413575c86204921543b72234464efcba88b29 (patch)
treebe76aeef095afbd7cc4b472118f55322451dd1fd /Makefile.am
parent3259be54400c65291b31bf42322d6e38721c9dbb (diff)
downloadlightdm-remote-session-remoteconfigure-7f1413575c86204921543b72234464efcba88b29.tar.gz
lightdm-remote-session-remoteconfigure-7f1413575c86204921543b72234464efcba88b29.tar.bz2
lightdm-remote-session-remoteconfigure-7f1413575c86204921543b72234464efcba88b29.zip
Add a script that will start the session
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am15
1 files changed, 15 insertions, 0 deletions
diff --git a/Makefile.am b/Makefile.am
index 9e0e749..d1882ce 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -16,6 +16,21 @@ EXTRA_DIST += uccsconfigure.desktop.in
CLEANFILES += uccsconfigure.desktop
###############################
+# The session script
+###############################
+
+session_startdir = $(pkglibexecdir)
+session_start_SCRIPTS = \
+ uccsconfigure-session
+
+uccsconfigure-session: uccsconfigure-session.in
+ @sed -e "s|\@pkglibexecdir\@|$(pkglibexecdir)|" $< > $@
+ @chmod +x $@
+
+EXTRA_DIST += uccsconfigure-session.in
+CLEANFILES += uccsconfigure-session
+
+###############################
# Dist check stuff
###############################