aboutsummaryrefslogtreecommitdiff
path: root/debian/rules
diff options
context:
space:
mode:
authorMike Gabriel <mike.gabriel@das-netzwerkteam.de>2017-04-26 13:26:47 +0200
committerMike Gabriel <mike.gabriel@das-netzwerkteam.de>2017-07-12 23:25:57 +0200
commit41ea54b0217175a4b78980671f4c6818eb66b166 (patch)
treea3c8b61e118fde6bd78a8dd8a1994d60aa08caaa /debian/rules
parent322e39b79729bc72bd37265949a04962e427ef0a (diff)
downloadnx-libs-41ea54b0217175a4b78980671f4c6818eb66b166.tar.gz
nx-libs-41ea54b0217175a4b78980671f4c6818eb66b166.tar.bz2
nx-libs-41ea54b0217175a4b78980671f4c6818eb66b166.zip
nxproxy: Switch to autoreconf.
This also solves the last remnant of overlinking as described in GH issue #133. Fixes ArcticaProject/nx-libs#133.
Diffstat (limited to 'debian/rules')
-rwxr-xr-xdebian/rules3
1 files changed, 2 insertions, 1 deletions
diff --git a/debian/rules b/debian/rules
index 707bdec54..1400c79bd 100755
--- a/debian/rules
+++ b/debian/rules
@@ -7,10 +7,11 @@ DPKG_EXPORT_BUILDFLAGS = 1
include /usr/share/dpkg/buildflags.mk
export LIBDIR = "/usr/lib/$(shell dpkg-architecture -qDEB_BUILD_MULTIARCH)"
+export LIBEXECDIR = "$(LIBDIR)/nx/bin"
export INCLUDEDIR = "/usr/include/$(shell dpkg-architecture -qDEB_BUILD_MULTIARCH)"
%:
- CONFIGURE="./configure --with-symbols --prefix=/usr --libdir=$(LIBDIR) --includedir=$(INCLUDEDIR)" dh $@ --with quilt
+ CONFIGURE="./configure --with-symbols --prefix=/usr --libdir=$(LIBDIR) --includedir=$(INCLUDEDIR) --libexecdir=$(LIBEXECDIR)" dh $@ --with quilt
override_dh_auto_clean:
rm -Rf nx-X11/.build-exports