aboutsummaryrefslogtreecommitdiff
path: root/nxcompshad/src/Makefile.am
diff options
context:
space:
mode:
authorMihai Moldovan <ionic@ionic.de>2018-02-25 04:33:52 +0100
committerMihai Moldovan <ionic@ionic.de>2018-02-25 04:33:52 +0100
commit990e61cc8931be57bda5526a69e6e204e1ee2dda (patch)
tree53ecb57ad8200789b9da9fdf230c0bfd162f440b /nxcompshad/src/Makefile.am
parentbe1ae7087f6e8aa3cb7b38e1c0717198c218efe9 (diff)
downloadnx-libs-990e61cc8931be57bda5526a69e6e204e1ee2dda.tar.gz
nx-libs-990e61cc8931be57bda5526a69e6e204e1ee2dda.tar.bz2
nx-libs-990e61cc8931be57bda5526a69e6e204e1ee2dda.zip
nxcompshad/{configure.ac,src/Makefile.am}: only enable new ELF dtags if target system actually is ELF-based.
Diffstat (limited to 'nxcompshad/src/Makefile.am')
-rw-r--r--nxcompshad/src/Makefile.am6
1 files changed, 5 insertions, 1 deletions
diff --git a/nxcompshad/src/Makefile.am b/nxcompshad/src/Makefile.am
index f7beac86e..4580149ad 100644
--- a/nxcompshad/src/Makefile.am
+++ b/nxcompshad/src/Makefile.am
@@ -39,10 +39,14 @@ AM_CPPFLAGS = \
libXcompshad_la_LDFLAGS = \
-version-number @LT_COMPSHAD_VERSION@ -no-undefined \
- -Wl,--enable-new-dtags \
-R '$(libdir)/nx/X11' \
$(NULL)
+if TARGET_ELF
+libXcompshad_la_LDFLAGS += \
+ -Wl,--enable-new-dtags \
+endif TARGET_ELF
+
libXcompshadincludedir = $(includedir)/nx
libXcompshadinclude_HEADERS = \
$(top_srcdir)/include/Shadow.h \