aboutsummaryrefslogtreecommitdiff
path: root/nxcompshad/src/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'nxcompshad/src/Makefile.am')
-rw-r--r--nxcompshad/src/Makefile.am6
1 files changed, 5 insertions, 1 deletions
diff --git a/nxcompshad/src/Makefile.am b/nxcompshad/src/Makefile.am
index f7beac86e..4580149ad 100644
--- a/nxcompshad/src/Makefile.am
+++ b/nxcompshad/src/Makefile.am
@@ -39,10 +39,14 @@ AM_CPPFLAGS = \
libXcompshad_la_LDFLAGS = \
-version-number @LT_COMPSHAD_VERSION@ -no-undefined \
- -Wl,--enable-new-dtags \
-R '$(libdir)/nx/X11' \
$(NULL)
+if TARGET_ELF
+libXcompshad_la_LDFLAGS += \
+ -Wl,--enable-new-dtags \
+endif TARGET_ELF
+
libXcompshadincludedir = $(includedir)/nx
libXcompshadinclude_HEADERS = \
$(top_srcdir)/include/Shadow.h \