aboutsummaryrefslogtreecommitdiff
path: root/nxdialog/configure.ac
diff options
context:
space:
mode:
authorMike Gabriel <mike.gabriel@das-netzwerkteam.de>2019-03-01 13:47:39 +0100
committerMike Gabriel <mike.gabriel@das-netzwerkteam.de>2019-03-01 15:20:18 +0100
commit57ca69fe09285ed7572d86f94e257484caa015a2 (patch)
treeb402739ddce203ab1504597400a0dcf90040005b /nxdialog/configure.ac
parentdf79c3b35a30a957be0125c42e766a7ea2f51123 (diff)
downloadnx-libs-57ca69fe09285ed7572d86f94e257484caa015a2.tar.gz
nx-libs-57ca69fe09285ed7572d86f94e257484caa015a2.tar.bz2
nx-libs-57ca69fe09285ed7572d86f94e257484caa015a2.zip
nxdialog: Turn into autotools project, add man page.
Diffstat (limited to 'nxdialog/configure.ac')
-rw-r--r--nxdialog/configure.ac22
1 files changed, 22 insertions, 0 deletions
diff --git a/nxdialog/configure.ac b/nxdialog/configure.ac
new file mode 100644
index 000000000..bc8e81b84
--- /dev/null
+++ b/nxdialog/configure.ac
@@ -0,0 +1,22 @@
+dnl ***************************************************************************
+dnl *** configure.ac for nxdialog ***
+dnl ***************************************************************************
+
+m4_define([nxdialog_version], m4_esyscmd([tr -d '\n' < VERSION]))
+
+# Initialize Autoconf
+AC_PREREQ(2.60)
+
+AC_INIT([NX Dialog], [nxdialog_version], [https://github.com/ArcticaProject/nx-libs/issues])
+AC_CONFIG_AUX_DIR([build-aux])
+AC_PREFIX_DEFAULT([/usr/local])
+
+AM_INIT_AUTOMAKE([foreign no-dist-gzip dist-bzip2])
+
+AC_CONFIG_FILES([
+Makefile
+bin/Makefile
+man/Makefile
+])
+
+AC_OUTPUT