aboutsummaryrefslogtreecommitdiff
path: root/nxproxy/configure.ac
diff options
context:
space:
mode:
authorMihai Moldovan <ionic@ionic.de>2017-09-29 17:19:06 +0200
committerMihai Moldovan <ionic@ionic.de>2017-10-27 08:45:42 +0200
commit1f717c6fdfa478f1c422bff51bc8574360dbe127 (patch)
tree44be7037766a0f332fb899fdfba1172acd212170 /nxproxy/configure.ac
parent39ee56f5dbe968cddebf6e7891667a2cf8b5af76 (diff)
downloadnx-libs-1f717c6fdfa478f1c422bff51bc8574360dbe127.tar.gz
nx-libs-1f717c6fdfa478f1c422bff51bc8574360dbe127.tar.bz2
nx-libs-1f717c6fdfa478f1c422bff51bc8574360dbe127.zip
nx{comp{,shad},proxy}: add configure flag --enable-cxx11 to enable and setup optional C++11 support.
Use AX_CXX_COMPILE_STDCXX(_11) from autotools archive. Note: should only be used in tandem. Make sure that each component either uses the C++11 ABI or none uses it. Mixing and matching libraries and binaries with different C++ ABIs might lead to weird errors.
Diffstat (limited to 'nxproxy/configure.ac')
-rw-r--r--nxproxy/configure.ac6
1 files changed, 6 insertions, 0 deletions
diff --git a/nxproxy/configure.ac b/nxproxy/configure.ac
index 9663fb4a8..cc8e898fc 100644
--- a/nxproxy/configure.ac
+++ b/nxproxy/configure.ac
@@ -23,6 +23,12 @@ AC_LANG([C])
NX_COMPILER_BRAND
NX_DEFAULT_OPTIONS
+AC_ARG_ENABLE([cxx11],
+ [AS_HELP_STRING([--enable-cxx11],
+ [enable optional features requiring C++11 support (disabled by default)])],
+ [AS_IF([test x$enableval = xyes],
+ [AX_CXX_COMPILE_STDCXX_11([], [mandatory])])])
+
AC_CONFIG_FILES([
Makefile
man/Makefile