aboutsummaryrefslogtreecommitdiff
path: root/nxproxy/configure.ac
diff options
context:
space:
mode:
Diffstat (limited to 'nxproxy/configure.ac')
-rw-r--r--nxproxy/configure.ac6
1 files changed, 6 insertions, 0 deletions
diff --git a/nxproxy/configure.ac b/nxproxy/configure.ac
index 9663fb4a8..cc8e898fc 100644
--- a/nxproxy/configure.ac
+++ b/nxproxy/configure.ac
@@ -23,6 +23,12 @@ AC_LANG([C])
NX_COMPILER_BRAND
NX_DEFAULT_OPTIONS
+AC_ARG_ENABLE([cxx11],
+ [AS_HELP_STRING([--enable-cxx11],
+ [enable optional features requiring C++11 support (disabled by default)])],
+ [AS_IF([test x$enableval = xyes],
+ [AX_CXX_COMPILE_STDCXX_11([], [mandatory])])])
+
AC_CONFIG_FILES([
Makefile
man/Makefile