aboutsummaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorRenato Araujo Oliveira Filho <renato.filho@canonical.com>2012-10-31 15:32:38 +0100
committerRenato Araujo Oliveira Filho <renato.filho@canonical.com>2012-10-31 15:32:38 +0100
commit4aee0f151e49148a6a51e996f42ec748ab58bbdb (patch)
tree5a5834556f6a5a8ccfa534964436f3dbddd97efa /CMakeLists.txt
parent7f4ba1a247c5032fd200ca9aad0d939ce6c0e9a5 (diff)
downloadqmenumodel-4aee0f151e49148a6a51e996f42ec748ab58bbdb.tar.gz
qmenumodel-4aee0f151e49148a6a51e996f42ec748ab58bbdb.tar.bz2
qmenumodel-4aee0f151e49148a6a51e996f42ec748ab58bbdb.zip
Revert last commit.
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt10
1 files changed, 10 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 261335a..d22194c 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -32,6 +32,16 @@ endif()
add_subdirectory(libqmenumodel)
# Tests Tools
+set(XVFB_EXEC "")
+option(USE_XVFB "Uses xvfb-run with the unit tests to avoid QtWidgets tests fails without X." FALSE)
+if(USE_XVFB)
+ find_program(XVFB_RUN NAMES xvfb-run)
+ if (NOT ${XVFB_RUN} MATCHES "XVFB_RUN-NOTFOUND")
+ set(XVFB_EXEC ${XVFB_RUN} -a)
+ message(STATUS "Using xvfb-run to perform QtWidget tests.")
+ endif()
+endif()
+
if(NOT DBUS_RUNNER)
message(STATUS "dbus-test-runner not found tests disabled.")
else()