aboutsummaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorRenato Araujo Oliveira Filho <renato.filho@canonical.com>2012-11-07 09:16:24 -0300
committerRenato Araujo Oliveira Filho <renato.filho@canonical.com>2012-11-07 09:16:24 -0300
commit664f1624e119c694aea2ed2ccd7e567594d0c069 (patch)
treedf0f390919626d01c27cf383aff14e003e0066d1 /CMakeLists.txt
parent21a895254bc08f111b5173f8b6b85f8271935020 (diff)
downloadqmenumodel-664f1624e119c694aea2ed2ccd7e567594d0c069.tar.gz
qmenumodel-664f1624e119c694aea2ed2ccd7e567594d0c069.tar.bz2
qmenumodel-664f1624e119c694aea2ed2ccd7e567594d0c069.zip
Make the rule 'make check' always enabled.
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt5
1 files changed, 3 insertions, 2 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 3cd501b..eb25369 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -35,11 +35,12 @@ add_subdirectory(libqmenumodel)
if(NOT DBUS_RUNNER)
message(STATUS "dbus-test-runner not found tests disabled.")
else()
+ # We need to enable test to create the 'make check' target mandatory on jenkins
+ enable_testing()
if(CMAKE_SYSTEM_PROCESSOR STREQUAL "armv7l")
message(STATUS "Current version of qemu crashes during the tests. We will skip it for now.")
else()
- message(STATUS "Enable tests for: ${CMAKE_SYSTEM_PROCESSOR}")
- enable_testing()
+ message(STATUS "Tests enabled for arch: ${CMAKE_SYSTEM_PROCESSOR}")
add_subdirectory(tests)
endif()
endif()