aboutsummaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt5
1 files changed, 3 insertions, 2 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 2730975..7f60630 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -35,11 +35,12 @@ add_subdirectory(libqmenumodel)
if(NOT DBUS_RUNNER)
message(STATUS "dbus-test-runner not found tests disabled.")
else()
+ # We need to enable test to create the 'make check' target mandatory on jenkins
+ enable_testing()
if(CMAKE_SYSTEM_PROCESSOR STREQUAL "armv7l")
message(STATUS "Current version of qemu crashes during the tests. We will skip it for now.")
else()
- message(STATUS "Enable tests for: ${CMAKE_SYSTEM_PROCESSOR}")
- enable_testing()
+ message(STATUS "Tests enabled for arch: ${CMAKE_SYSTEM_PROCESSOR}")
add_subdirectory(tests)
endif()
endif()