aboutsummaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorRenato Araujo Oliveira Filho <renato.filho@canonical.com>2012-11-07 09:54:44 -0300
committerRenato Araujo Oliveira Filho <renato.filho@canonical.com>2012-11-07 09:54:44 -0300
commit67680f3a61e0e64bf46a63eb4ce7ce3091f1335a (patch)
tree904b3c37a881caefe78ccfaca6d1dd28d782fce6 /CMakeLists.txt
parente6cddf7b3b77b119e54577af420fe00bceee9e3a (diff)
parent664f1624e119c694aea2ed2ccd7e567594d0c069 (diff)
downloadqmenumodel-67680f3a61e0e64bf46a63eb4ce7ce3091f1335a.tar.gz
qmenumodel-67680f3a61e0e64bf46a63eb4ce7ce3091f1335a.tar.bz2
qmenumodel-67680f3a61e0e64bf46a63eb4ce7ce3091f1335a.zip
Merged 'lp:~renatofilho/girden/debian-dh'.
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt5
1 files changed, 3 insertions, 2 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 2730975..7f60630 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -35,11 +35,12 @@ add_subdirectory(libqmenumodel)
if(NOT DBUS_RUNNER)
message(STATUS "dbus-test-runner not found tests disabled.")
else()
+ # We need to enable test to create the 'make check' target mandatory on jenkins
+ enable_testing()
if(CMAKE_SYSTEM_PROCESSOR STREQUAL "armv7l")
message(STATUS "Current version of qemu crashes during the tests. We will skip it for now.")
else()
- message(STATUS "Enable tests for: ${CMAKE_SYSTEM_PROCESSOR}")
- enable_testing()
+ message(STATUS "Tests enabled for arch: ${CMAKE_SYSTEM_PROCESSOR}")
add_subdirectory(tests)
endif()
endif()