aboutsummaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt9
1 files changed, 7 insertions, 2 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index f90507e..2730975 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -35,8 +35,13 @@ add_subdirectory(libqmenumodel)
if(NOT DBUS_RUNNER)
message(STATUS "dbus-test-runner not found tests disabled.")
else()
- enable_testing()
- add_subdirectory(tests)
+ if(CMAKE_SYSTEM_PROCESSOR STREQUAL "armv7l")
+ message(STATUS "Current version of qemu crashes during the tests. We will skip it for now.")
+ else()
+ message(STATUS "Enable tests for: ${CMAKE_SYSTEM_PROCESSOR}")
+ enable_testing()
+ add_subdirectory(tests)
+ endif()
endif()
# Doc