aboutsummaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorRenato Araujo Oliveira Filho <renato.filho@canonical.com>2012-11-07 08:43:47 -0300
committerRenato Araujo Oliveira Filho <renato.filho@canonical.com>2012-11-07 08:43:47 -0300
commit987dd978d5fd341d57dba0a735c08caff2807609 (patch)
treec0281348eee7494a780a9b7ec25876b93972ff53 /CMakeLists.txt
parentcba9178ec3d1956798e730585f89ecc363040085 (diff)
parent21a895254bc08f111b5173f8b6b85f8271935020 (diff)
downloadqmenumodel-987dd978d5fd341d57dba0a735c08caff2807609.tar.gz
qmenumodel-987dd978d5fd341d57dba0a735c08caff2807609.tar.bz2
qmenumodel-987dd978d5fd341d57dba0a735c08caff2807609.zip
Merged 'lp:~renatofilho/girden/debian-dh' branch.
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt9
1 files changed, 7 insertions, 2 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index f90507e..2730975 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -35,8 +35,13 @@ add_subdirectory(libqmenumodel)
if(NOT DBUS_RUNNER)
message(STATUS "dbus-test-runner not found tests disabled.")
else()
- enable_testing()
- add_subdirectory(tests)
+ if(CMAKE_SYSTEM_PROCESSOR STREQUAL "armv7l")
+ message(STATUS "Current version of qemu crashes during the tests. We will skip it for now.")
+ else()
+ message(STATUS "Enable tests for: ${CMAKE_SYSTEM_PROCESSOR}")
+ enable_testing()
+ add_subdirectory(tests)
+ endif()
endif()
# Doc