aboutsummaryrefslogtreecommitdiff
path: root/mesalib/configure.ac
diff options
context:
space:
mode:
authormarha <marha@users.sourceforge.net>2014-05-29 20:50:12 +0200
committermarha <marha@users.sourceforge.net>2014-05-29 20:50:12 +0200
commitaec798fb4dc72d616732d0fa711faffaa8cd7590 (patch)
tree2814dfe69e7fb25b57492244d5cfa59d80fc8837 /mesalib/configure.ac
parent78c6c2b88ae54977a2a617f116a1598657a98b6f (diff)
parent816a5430313e07083c5325f0a430126a2e10ec41 (diff)
downloadvcxsrv-aec798fb4dc72d616732d0fa711faffaa8cd7590.tar.gz
vcxsrv-aec798fb4dc72d616732d0fa711faffaa8cd7590.tar.bz2
vcxsrv-aec798fb4dc72d616732d0fa711faffaa8cd7590.zip
Merge remote-tracking branch 'origin/released'
Conflicts: mesalib/src/mesa/drivers/dri/common/dri_util.c
Diffstat (limited to 'mesalib/configure.ac')
-rw-r--r--mesalib/configure.ac7
1 files changed, 7 insertions, 0 deletions
diff --git a/mesalib/configure.ac b/mesalib/configure.ac
index 7397341b2..bee85a131 100644
--- a/mesalib/configure.ac
+++ b/mesalib/configure.ac
@@ -1728,6 +1728,13 @@ if test "x$enable_gallium_llvm" = xyes; then
if $LLVM_CONFIG --components | grep -qw 'option'; then
LLVM_COMPONENTS="${LLVM_COMPONENTS} option"
fi
+ # Current OpenCL/Clover and LLVM 3.5 require ObjCARCOpts and ProfileData
+ if $LLVM_CONFIG --components | grep -qw 'objcarcopts'; then
+ LLVM_COMPONENTS="${LLVM_COMPONENTS} objcarcopts"
+ fi
+ if $LLVM_CONFIG --components | grep -qw 'profiledata'; then
+ LLVM_COMPONENTS="${LLVM_COMPONENTS} profiledata"
+ fi
fi
DEFINES="${DEFINES} -DHAVE_LLVM=0x0$LLVM_VERSION_INT -DLLVM_VERSION_PATCH=$LLVM_VERSION_PATCH"
MESA_LLVM=1