aboutsummaryrefslogtreecommitdiff
path: root/xorg-server/test/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'xorg-server/test/Makefile.am')
-rw-r--r--xorg-server/test/Makefile.am5
1 files changed, 2 insertions, 3 deletions
diff --git a/xorg-server/test/Makefile.am b/xorg-server/test/Makefile.am
index 689dd7f60..62c398c18 100644
--- a/xorg-server/test/Makefile.am
+++ b/xorg-server/test/Makefile.am
@@ -1,10 +1,10 @@
if ENABLE_UNIT_TESTS
-if HAVE_LD_WRAP
SUBDIRS= . xi2
-noinst_PROGRAMS = xkb input xtest list misc fixes xfree86
+noinst_PROGRAMS = xkb input xtest list misc fixes xfree86 string
check_LTLIBRARIES = libxservertest.la
TESTS=$(noinst_PROGRAMS)
+TESTS_ENVIRONMENT = $(XORG_MALLOC_DEBUG_ENV)
AM_CFLAGS = $(DIX_CFLAGS) @XORG_CFLAGS@
INCLUDES = $(XORG_INCS) -I$(top_srcdir)/hw/xfree86/parser \
@@ -43,4 +43,3 @@ libxservertest_la_LIBADD = \
@XORG_LIBS@
libxservertest_la_DEPENDENCIES = $(libxservertest_la_LIBADD)
endif
-endif