aboutsummaryrefslogtreecommitdiff
path: root/debian
diff options
context:
space:
mode:
authorRobert Tari <robert@tari.in>2020-11-08 13:50:13 +0100
committerRobert Tari <robert@tari.in>2020-11-10 12:10:27 +0100
commitf9a39b44803e6347c72c1edd8ba46f633e99dd57 (patch)
tree558d0879ddc9318f7e9c0bb7362fd7f086fa29f0 /debian
parentf872e9097ff373a172119bd3f7e9d0ef84b31ce1 (diff)
downloadayatana-indicator-notifications-f9a39b44803e6347c72c1edd8ba46f633e99dd57.tar.gz
ayatana-indicator-notifications-f9a39b44803e6347c72c1edd8ba46f633e99dd57.tar.bz2
ayatana-indicator-notifications-f9a39b44803e6347c72c1edd8ba46f633e99dd57.zip
Rewrite to indicator-ng, simplify, drop all GTK references, move to CMake
fixes #9, fixes #12
Diffstat (limited to 'debian')
-rw-r--r--debian/control24
-rwxr-xr-xdebian/rules32
2 files changed, 24 insertions, 32 deletions
diff --git a/debian/control b/debian/control
index f5db253..b35a063 100644
--- a/debian/control
+++ b/debian/control
@@ -4,17 +4,19 @@ Priority: optional
Maintainer: Jason Conti <jason.conti@gmail.com>
Uploaders:
Mike Gabriel <mike.gabriel@das-netzwerkteam.de>
-Build-Depends: debhelper (>= 9),
- dh-autoreconf | debhelper (>= 9.20160403~),
- dh-systemd | debhelper (>= 10.2~),
+Build-Depends: cmake,
+ cmake-extras (>= 0.10),
+ gcovr,
+ lcov,
+ libnotify-dev (>= 0.7.6),
+ libglib2.0-dev (>= 2.36),
+ liburl-dispatcher1-dev | hello,
+# for packaging
+ debhelper (>= 9),
+ dpkg-dev (>= 1.16.1.1),
intltool,
- libayatana-indicator-dev (>= 0.3.93),
- libayatana-indicator3-dev (>= 0.3.93),
- libglib2.0-dev (>= 2.29),
- libgdk-pixbuf2.0-dev (>= 2.22),
- libgtk-3-dev (>= 3.1),
- mate-common,
- pkg-config,
+
+# for systemd unit
systemd [linux-any],
Standards-Version: 4.1.3
Homepage: https://github.com/AyatanaIndicators/ayatana-indicator-notifications
@@ -25,7 +27,7 @@ Package: ayatana-indicator-notifications
Architecture: any
Depends: ${shlibs:Depends},
${misc:Depends},
- libglib2.0-bin,
+ ayatana-indicator-common,
Description: Ayatana Indicator for viewing recent notifications
An Ayatana Indicator applet to display recent notifications sent to a
notification daemon such as notify-osd.
diff --git a/debian/rules b/debian/rules
index 7382e4d..90fda29 100755
--- a/debian/rules
+++ b/debian/rules
@@ -1,35 +1,25 @@
#!/usr/bin/make -f
+# -*- makefile -*-
-DPKG_GENSYMBOLS_CHECK_LEVEL=4
+# Uncomment this to turn on verbose mode.
+#export DH_VERBOSE=1
+
+export DPKG_GENSYMBOLS_CHECK_LEVEL=4
export DEB_BUILD_MAINT_OPTIONS = hardening=+all
DPKG_EXPORT_BUILDFLAGS = 1
include /usr/share/dpkg/buildflags.mk
%:
- dh $@ --with autoreconf,systemd
-
-override_dh_autoreconf:
- if [ ! -e po/ayatana-indicator-notifications.pot.bak ]; then \
- cp po/ayatana-indicator-notifications.pot po/ayatana-indicator-notifications.pot.bak; \
- fi
- NOCONFIGURE=1 dh_autoreconf ./autogen.sh
-
-override_dh_auto_configure:
- dh_auto_configure -- \
- --disable-static
+ dh $@ --with systemd
-override_dh_auto_install:
- dh_auto_install
+override_dh_install:
find debian/ayatana-indicator-notifications -name \*.la -delete
+ find debian/ayatana-indicator-notifications -name \*.a -delete
+ dh_install --fail-missing
override_dh_installchangelogs:
dh_installchangelogs NEWS
-override_dh_auto_clean:
- dh_auto_clean
- if [ -e po/ayatana-indicator-notifications.pot.bak ]; then \
- mv -f po/ayatana-indicator-notifications.pot.bak po/ayatana-indicator-notifications.pot; \
- fi
- rm -f config.guess
- rm -f config.sub
+get-orig-source:
+ uscan --noconf --force-download --rename --download-current-version --destdir=..